Service Admin EU seems to be down

Major incident Admin EU
2019-03-07 13:10 CEST · 6 minutes, 1 second

Updates

Resolved

Service is back up.

March 7, 2019 · 13:16 CEST
Issue

Our monitoring system has found out the service Admin EU is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

March 7, 2019 · 13:10 CEST

← Back