Service Admin EU seems to be down

Major incident Admin EU
2019-09-16 03:27 CEST · 2 minutes

Updates

Resolved

Service is back up.

September 16, 2019 · 03:29 CEST
Issue

Our monitoring system has found out the service Admin EU is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

September 16, 2019 · 03:27 CEST

← Back