Service Admin EU seems to be down

Major incident Admin EU
2018-12-10 11:29 CEST · 20 minutes, 38 seconds

Updates

Resolved

Service is back up.

December 10, 2018 · 11:50 CEST
Issue

Our monitoring system has found out the service Admin EU is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

December 10, 2018 · 11:29 CEST

← Back